ACC: Troubleshoot "Couldn't Find Installable ISAM" Error

Last reviewed: March 11, 1998
Article ID: Q155666
The information in this article applies to:
  • Microsoft Access versions 7.0, 97

SYMPTOMS

Moderate: Requires basic macro, coding, and interoperability skills.

When you try to export data to Microsoft FoxPro, Paradox, dBASE, Lotus 1-2-3, or Microsoft Excel files you may receive the following error message:

   Couldn't find installable ISAM

You may also receive this error when you try to import data from one of those file types.

CAUSE

This error can be caused by invalid information in the Windows registry, or by a missing or a corrupted dynamic-link library (.dll) file.

RESOLUTION

The following steps show you how to remove and then reinstall the indexed sequential access method (ISAM) drivers in Microsoft Access 95 or Microsoft Access 97:

  1. Start Windows Explorer (or File Manager) and search for the following
     file names. If you find any of these files, rename them.

     In Microsoft Access 95:

        File Name       Import/Export ISAM For
        --------------------------------------
        Msxl3032.dll    Microsoft Excel
        Mstx3032.dll    Text
        Mslt3032.dll    Lotus 1-2-3
        Mspx3032.dll    Paradox
        Msxb3032.dll    Microsoft FoxPro
        Msxb3032.dll    dBase

     In Microsoft Access 97:

        File Name       Import/Export ISAM For
        --------------------------------------
        Msexcl35.dll    Microsoft Excel
        Mstext35.dll    Text
        Msltus35.dll    Lotus 1-2-3
        Mspdox35.dll    Paradox
        Msxbse35.dll    Microsoft FoxPro
        Msxbse35.dll    dBase

  2. If you have Microsoft Access as a stand-alone product, start the
     Setup program for your version of Microsoft Access (95 or 97). Or
     if you have Microsoft Access as a component of Microsoft Office
     Professional for Windows, start the Setup program for your version
     of Office Professional (95 or 97).

  3. Click the Add/Remove button.

     NOTE: If you are running Setup for Microsoft Office 95 or
     Professional, select Microsoft Access in the Options box, and then
     click Change Option before you proceed to step 4.

  4. Select Data Access in the Options box, and then click Change Option.

  5. Clear the check box for each driver that has a check mark next to it.

  6. Click Continue. Follow the instructions on screen to complete the
     process of removing the ISAM components.

  7. Start the Setup program again to reinstall the ISAM drivers.

  8. Click the Add/Remove button.

     NOTE: If you are running Setup for Microsoft Office 95 or 97
     Professional, select Microsoft Access in the Options box, and then
     click Change Option before you proceed to step 9.

  9. Select Data Access in the Options box, and then click Change Option.

 10. Click to select the check box for each ISAM driver you want to
     reinstall.

 11. Click Continue. Follow the instructions on screen to complete the
     process of reinstalling the ISAM components.

If the error message continues, remove and then reinstall Microsoft Access. The following steps show you how to remove and then reinstall Microsoft Access:

  1. Back up all the Microsoft Access database (.mdb) files that you have created.

  2. If you have Microsoft Access as a stand-alone product, start the Setup program for your version of Microsoft Access (95 or 97). Or if you have Microsoft Access as a component of Microsoft Office Professional for Windows, start the Setup program for your version of Office Professional (95 or 97).

  3. Remove Microsoft Access using one of the following methods:

        a. If you have Microsoft Access as a stand-alone product, in the
           Installation Maintenance Program box, click Remove All.
    

        b. If you have Microsoft Access as a component of Microsoft Office
           Professional, in the Installation Maintenance Program box, click
           Add/Remove, and then click to clear the Microsoft Access check box.
           Click Continue.
    

  4. Follow the instructions on screen to complete the process of removing Microsoft Access 95 or Microsoft Access 97.

  5. Start Windows Explorer (or File Manager) and search for the following file names. If you find any of these files, rename them:

    In Microsoft Access 95:

           File Name       Import/Export ISAM For
           --------------------------------------
           Msxl3032.dll    Microsoft Excel
           Mstx3032.dll    Text
           Mslt3032.dll    Lotus 1-2-3
           Mspx3032.dll    Paradox
           Msxb3032.dll    Microsoft FoxPro
           Msxb3032.dll    dBase
    
       In Microsoft Access 97:
    
           File Name       Import/Export ISAM For
           --------------------------------------
           Msexcl35.dll    Microsoft Excel
           Mstext35.dll    Text
           Msltus35.dll    Lotus 1-2-3
           Mspdox35.dll    Paradox
           Msxbse35.dll    Microsoft FoxPro
           Msxbse35.dll    dBase
    
    

  6. Insert Disk 1 of the Microsoft Access 95/Microsoft Access 97 disks into a floppy drive on your computer, or insert the Microsoft Office Professional 95/Microsoft Office 97 Professional CD into a CD-ROM drive.

  7. Reinstall Microsoft Access using one of the following methods:

        a. If you are installing Microsoft Access as a stand-alone product,
           type a command to start Setup, and then follow the instructions to
           install Microsoft Access on your computer. For example:
    

              a:\setup
    
        b. If you are installing Microsoft Access as a component of Microsoft
           Office Professional, start Setup, click the Add/Remove button, and
           then click the Microsoft Access check box. Click Continue and
           follow the instructions on screen to install Microsoft Access.
    
    

REFERENCES

For more information about ISAM settings in the Windows registry, search on the phrase "ISAM," and then view "Customize Windows Registry settings used by Microsoft Access," or ask the Office Assistant.


Additional query words: attach link
Keywords : IsmProb kb3rdparty kberrmsg
Version : 7.0 97
Platform : WINDOWS
Hardware : x86
Issue type : kbprb
Solution Type : Info_Provided


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Last reviewed: March 11, 1998
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