XCLN: Unable to Open Forms Because Files are Missing

Last reviewed: April 9, 1997
Article ID: Q146672
The information in this article applies to:

- Microsoft Exchange Windows 95 client, versions 4.0 and 5.0 - Microsoft Exchange Windows 3.x client, versions 4.0 and 5.0 - Microsoft Exchange Windows NT client, versions 4.0 and 5.0

SYMPTOMS

After installing one of the custom applications located in the Exchsrvr\Samples directory on the Microsoft Exchange Server, a client will receive the following error when attempting to use one of these forms:

   Unable to open <form name> Form<s> because some files are missing on
   your machine. The Microsoft Forms Designer tool must be installed.

This error occurs even though a dialog was displayed telling the client that the form has been installed on the computer.

CAUSE

When a form is installed on a client computer, only the main executable is installed. Any supporting Dll’s will need to be installed to the client computer by running the Microsoft Exchange Electronic Forms Designer (EFD) Setup program.

RESOLUTION

There are two methods of installing the supporting Dll’s without having to keep the Microsoft Exchange EFD installed on the computer.

The first is to run the Microsoft Exchange EFD Setup program on the client computer and then re-run setup and choosing to Remove All. This will uninstall the Microsoft Exchange EFD, however, the supporting Dll's will remain as they are considered shared components and are not removed.

The second method is to manually copy over the needed files from a computer that has the Microsoft Exchange EFD installed. The necessary files are:

Dao2516.dll Msajt200.dll Vaen21.olb Msjeterr.dll Vbajet.dll Msjetint.dll Vbdb16.dll

Copy these 7 files into the <winroot>\system directory on Windows 95 or Windows 3.x and to the <winroot>\system32 on Windows NT.

NOTE: Installing the 16-bit version of Microsoft Visual Basic 4.0 will also place these files on the client computer.

STATUS

Microsoft has confirmed this to be a problem in version 4.0 of Microsoft Exchange. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Additional query words: EFD survey form
Keywords : kbsetup XCLN
Version : 4.0
Platform : WINDOWS
Issue type : kberrmsg


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Last reviewed: April 9, 1997
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