Office 4.x Err Msg: "Insufficient Memory to Run Application"

Last reviewed: September 16, 1996
Article ID: Q118457
The information in this article applies to:
  • Microsoft Office for Windows, versions 4.2, 4.3
  • Microsoft Word for Windows, versions 6.0, 6.0a, 6.0c
  • Microsoft PowerPoint for Windows, versions 4.0, 4.0a, 4.0c

SYMPTOMS

When you run the Microsoft Office Setup from disks, the installation initially appears to run successfully. However, after 10 to 20 seconds, the system may return the following error message:

   Insufficient memory to run application. 900K required.

CAUSE

During Setup a temporary (temp) directory will be written to the last available local drive.

This error message appears because of an incorrect tempdir setting in the SETUP.LST. The TmpDirSize is set to 900, but it should be set to 2500.

Note that simply changing the tempdir setting will not resolve the problem if you do not have a valid temp directory. For example, the set temp line in your Autoexec.bat points to a directory that doesn't exist.

Compressed drives that have less than 2.5 megabytes (MB) on the uncompressed drive may also receive an insufficent memory message.

RESOLUTION

To correct this problem, do the following:

  1. Make a backup copy of the SETUP.LST file (located on Setup Disk 1).

  2. In Notepad, open the SETUP.LST file.

  3. Change the tempdir setting (TmpDirSize) in the SETUP.LST to 2500 rather than 900.

You should also check for the existence of the directory ~MSSTFQF.T. If this directory exists, delete it. Setup will fail if it finds ~MSSTFQF.T.

Sample of Original File

[Params]

   WndTitle   = Microsoft Office Setup
   WndMess    = Starting Office Setup, please wait...
 ***Change the next line to TmpDirSize = 2500
   TmpDirSize = 900
   TmpDirName = ~msstfqf.t
   CmdLine    = acmsetup /T setup.stf /S %s %s
   DrvModName = ACMSETUP
   Require31  = This program requires Windows (R) 3.1 or higher.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft Products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q113432
   TITLE     : Office Error Msg: "Cannot Find CTL3D.DLL" During
               Installation


KBCategory: kbsetup kberrmsg
KBSubcategory: offwin

Additional reference words: 4.20 4.30 900kb 2500k 2500kb word6 powerpt
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Last reviewed: September 16, 1996
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