OL97: Cannot Run SR-1 Patch if Outlook 8.03 is Installed

Last reviewed: March 12, 1998
Article ID: Q177881
The information in this article applies to:
  • Microsoft Outlook 97

SYMPTOMS

When you attempt to run the Microsoft Office Service Release 1 (SR-1) patch you may encounter the following error:

   The Patch has determined that your installation of Office cannot be
   updated at this time. Shutdown all running applications and re-run the
   patch, if the problem persists please consult the Microsoft Knowledge
   Base at http://www.microsoft.com/kb.

The steps contained in this article are relevent to applying the patch with Outlook 98. For information written specifically for Outlook98, please refer to Q180228.

NOTE: Because the Microsoft Web site is constantly updated, the site address may change without notice. If this occurs, link to the Microsoft home page at the following address:

   http://www.microsoft.com/

CAUSE

This problem may occur because you have installed Microsoft Outlook 97 version 8.03. This release of Outlook updates the following Office support files:

   Mso97.dll
   Mso7enu.dll

The newer versions of these files cannot be updated by the SR-1 patch.

RESOLUTION

There are two methods to resolve this problem.

Method 1

  1. Uninstall Outlook 8.03. You will be prompted to remove the Windows messaging System components; do not remove these components.

  2. Install the desired programs from the Office 97 compact disc.

  3. Apply the SR-1 patch.

  4. Install Outlook 8.03.

Method 2

  1. Locate the files, Mso97.dll and Mso7enu.dll in the Office folder and copy them to a temporary folder.

  2. Copy the original versions of mso97.dll and ms07enu.dll from the Office 97 compact disc to the Office folder on your computer.

  3. You should be able to apply the SR-1 patch since the older but correct versions of the key files are in the Office folder

MORE INFORMATION

Steps to Reproduce Problem

  1. Install Office 97 or any Office 97 program.

  2. Install Outlook 8.03.

  3. Attempt to run the SR-1 patch.

    -or-

  4. Install Outlook 8.03.

  5. Install any version of Office 97 or the standalone Outlook 97. Each version should be prior to the SR-1 upgrade.

  6. Attempt to run the SR-1 patch.

RESULTS: The error message in the SYMPTOMS section will appear.
Keywords          : StpOthr
Version           : WINDOWS:97
Platform          : WINDOWS
Issue type        : kbprb
Solution Type     : kbworkaround


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 12, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.