PC Forms: MEFROUTE.XLA Will Not Route Excel 5 Workbooks

Last reviewed: June 5, 1996
Article ID: Q137351
The information in this article applies to:
  • Microsoft Electronic Forms Designer, version 1.0

SYMPTOMS

The Microsoft Excel macro, MEFROUTE.XLA, included with Microsoft Electronic Forms Designer, will not allow you to route workbooks from Microsoft Excel version 5.0 or later. The workbook is sent successfully, but the recipient receives the following error when he or she tries to open the attachment:

   The attached file [BOOK1.XLS]Sheet1 could not be opened because a
   temporary file could not be created."

CAUSE

The MEFROUTE.XLA shipped with Microsoft Electronic Forms Designer was written for Microsoft Excel versions 3.0 and 4.0. Because of changes in the way Microsoft Excel version 5.0 and later use workbooks with sheet tabs, the routing macro needs to be edited to route workbooks successfully.

RESOLUTION

You can find MEFROUTE.EXE (size: 18959 bytes) 
                         , a self-extracting file, on the following
services:
  • Microsoft's World Wide Web Site on the Internet

          On the www.microsoft.com home page, click the Support icon.
          Click Knowledge Base, and select the product.
    
          Enter kbfile MEFROUTE.EXE (size: 18959 bytes) 
                                   , and click GO!
          Open the article, and click the button to download the file.
    
    
  • Internet (anonymous FTP)

          ftp ftp.microsoft.com
          Change to the Softlib/Mslfiles folder.
          Get MEFROUTE.EXE (size: 18959 bytes) 
    
  • The Microsoft Network

          On the Edit menu, click Go To, and then click Other Location.
          Type "mssupport" (without the quotation marks).
          Double-click the MS Software Library icon.
          Find the appropriate product area.
          Locate and Download MEFROUTE.EXE.
    
  • Microsoft Download Service (MSDL)

          Dial (206) 936-6735 to connect to MSDL
          Download MEFROUTE.EXE (size: 18959 bytes) 
    

For additional information about downloading, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online
               Services


Additional reference words: 3.20 mefroute.xla eforms
KBCategory: kbinterop
KBSubcategory: MailPCForms


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 5, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.