SMS: ScanDisk Runs After a Remote Reboot of a Win95 OSR2 Client

Last reviewed: February 13, 1998
Article ID: Q181081
The information in this article applies to:
  • Microsoft Systems Management Server, versions 1.1 and 1.2

SYMPTOMS

When you use the Remote Reboot feature of Systems Management Server on a client computer running Windows 95 OEM Service Release 2 (OSR2), the following message is displayed during the restart:

   Windows was not properly shut down. One or more of your disk drives may
   have errors on it. Press any key to run ScanDisk on these drives.

CAUSE

Remote Reboot issues a CPU reset instruction, not a graceful shutdown.

WORKAROUND

To work around this problem, do any one of the following:

  • Open the Msdos.sys file and add the following line to the [Options] section:

          Autoscan=0
    

    NOTE: This method completely disables the OSR2 Autoscan feature. The kernel does not check the Clean Shutdown and Hard Disk Error bits, and ScanDisk is not started.

  • Obtain the hotfix mentioned in STATUS section below. This fix should have the following timestamp:

          2/9/98   10:05am         144,896    Idisp16.dll
    
    
  • Wait for the next Systems Management Server service pack.

STATUS

Microsoft has confirmed this to be a problem in Systems Management Server versions 1.1 and 1.2. A supported fix is now available, but has not been fully regression- tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

Windows 95 OSR2 includes versions of the Io.sys and Win.com files that check the Clean Shutdown and Hard Disk Error bits in the Virtual File Allocation Table (VFAT) during startup. If either of these bits is enabled (that is, cleared to 0) on any drive present in real mode, you are prompted to run ScanDisk. If you do not press a key within 60 seconds, ScanDisk runs anyway.


Additional query words: prodsms osr windows95 win95 win original
equipment manufacturer
Keywords : kbbug1.10 kbbug1.20 smsremtshoot kbbuglist
Version : winnt:1.1 1.2
Platform : WINDOWS
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbpatch


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Last reviewed: February 13, 1998
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