RECEIVE_ALLOCATE Hangs on Windows NT SNA Server Client

Last reviewed: November 22, 1995
Article ID: Q140026
The information in this article applies to:
  • Microsoft SNA Server for Windows NT, version 2.11

SYMPTOMS

When you run a 32-bit Windows APPC application on an SNA Server Windows NT client, the following symptoms occur:

NOTE: These symptoms do not occur when you run the application on the SNA server.

  • A transaction program name of SASRMT is registered as an autostarted invokable transaction program (with a service type of 0x05). An incoming attach is received which starts up the application.
  • This application then issues a RECEIVE_ALLOCATE on the SASTP62 TP name, which is configured as a queued operator started transaction program (with a service type of 0x1A). However, this receive allocate hangs indefinitely.

The SNA Server receives the attach request on the SASTP62 name, though it is never routed to the Windows NT client computer.

This problem does not occur with autostarted invokable transaction programs.

NOTE: It is possible to configure a Timeout value for the invokable transaction program within the Windows NT registry (for Win32 applications) or WIN.INI (for Win 3.x applications) so that the RECEIVE_ALLOCATE does not wait forever. See the SNA Server APPC and CPIC Programmer's Guide, Chapter 2 for information about the Timeout parameter.

CAUSE

The SNA Server Windows NT client does not promptly notify SNA Server that the operator started transaction program was started. When the attach request arrives at the SNA Server from the remote system, the server does not know which client to route the request to.

RESOLUTION

Install the latest SNA Server U.S. Service Pack.

An update to the SNA Server Windows NT client software corrects this problem by reducing the time to send service table updates.

STATUS

Microsoft has confirmed this to be a problem in SNA Server 2.11. A fix to this problem is in development, but has not been regression-tested and may be destabilizing in production environments. Microsoft does not recommend implementing this fix at this time. Contact Microsoft Product Support Services for more information on the availability of this fix.


KBCategory: kbnetwork kbprg kbbug2.11 kbfix211.sp1
KBSubcategory: ntnetserv
Additional reference words: prodsna 2.11


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Last reviewed: November 22, 1995
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