Setup Detects Disk Errors but SCANDISK /ALL Does Not

Last reviewed: September 7, 1995
Article ID: Q130071
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

You receive the following error message when you are running Windows 95 Setup to upgrade an existing Windows 95 installation:

   Setup checked the hard disk(s) on your computer and found that
   there may be problems. You need to check your disk(s) before
   continuing Setup.

   To repair these problems, quit Setup and then run ScanDisk from
   Windows. Then run Setup again.

When you run ScanDisk in Windows 95, no errors are reported.

CAUSE

This error message can occur if there is a damaged DoubleSpace or DriveSpace compressed volume file (CVF) that is not mounted. The ScanDisk test run by Windows 95 Setup checks unmounted CVFs.

RESOLUTION

To work around this behavior, use either of the following methods:

  • Run ScanDisk on the unmounted CVF by typing the following line at a command prompt

          scandisk <drive>:\<dblspace.nnn>
    

    where <drive> is the letter of the hard disk containing the CVF and <dblspace.nnn> is the name of the CVF. Note that the CVF may be named DRVSPACE.<nnn>.

  • Rename the CVF file so that Setup will not check it and then run Setup again. To rename the CVF file, type the following line at a command prompt

          ren <drive>:\<dblspace.nnn> dscvf.<nnn>
    

    where <drive> is the letter of the hard disk containing the CVF, <dblspace.nnn> is the name of the CVF, and <nnn> is the extension of the CVF. Note that the CVF may be named DRVSPACE.<nnn>.

    NOTE: The unmounted CVF may have its Hidden, System, or Read-Only attributes set. Before you rename the file you may have to remove these attributes. To do so, type the following line at a command prompt

          attrib -s -h -r <drive>:\<dblspace.nnn>
    

    where <drive> is the letter of the hard disk containing the CVF and <dblspace.nnn> is the name of the CVF. Note that the CVF may be named DRVSPACE.<nnn>.

MORE INFORMATION

When you run Windows 95 Setup from MS-DOS or Windows 3.x, Setup does not check unmounted CVFs. Setup checks unmounted CVFs only when you run Setup from an existing Windows 95 installation.


KBCategory: kbsetup kbtool kberrmsg
KBSubcategory: wpp95 win95 scandisk
Additional reference words: 95 scandskw


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 7, 1995
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.