Second Instance of ScanDisk Returns Incorrect Exit Code

Last reviewed: September 7, 1995
Article ID: Q135958
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Plus! for Windows 95

SYMPTOMS

If you schedule two ScanDisk tasks in System Agent that overlap, the second task quits immediately with an exit code of 0. This causes ScanDisk to report that no errors were found, even though ScanDisk did not complete its scan.

CAUSE

You can run only one instance of ScanDisk at a time. If you try to start a second instance, the second instance quits immediately, and generates an incorrect exit code.

RESOLUTION

Do not schedule two ScanDisk tasks in System Agent that overlap.


KBCategory: kbtool
KBSubcategory: plusfest win95 winplus
Additional reference words: 95


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 7, 1995
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.