Problems with Removable IDE Drives in Windows 95

Last reviewed: January 8, 1998
Article ID: Q153471
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

When you are using certain removable IDE disk drives in Windows 95, one or more of the following symptoms may occur:

  • The removable drive is not detected or not accessible within Windows 95.
  • Media changes, such as removing a disk and inserting a new disk, are not detected and are not reflected in Windows Explorer.
  • The removable drive appears as a non-removable hard disk in Windows Explorer or Device Manager.

CAUSE

Removable IDE disk drives are not fully supported by the IDE drivers included with Windows 95.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95. An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time.

This issue is resolved by the following updated files for Windows 95:

   Esdi_506.pdr version 4.00.954 (dated 2/26/96) and later
   Voltrack.vxd version 4.00.954 (dated 3/6/96) and later

To install this update, follow these steps:

  1. Download the Remideup.exe file from the Microsoft Software Library to an empty folder.

  2. In My Computer or Windows Explorer, double-click the Remideup.exe file you downloaded in step 1.

  3. Follow the instructions on the screen.

The following file is available for download from the Microsoft Software Library:

 ~ Remideup.exe (size: 147096 bytes) 

For more information about downloading files from the Microsoft Software Library, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online Services

The following files are installed by Remideup.exe:

 File name     Version    Date/Time       Size    Destination folder
 ------------------------------------------------------------------------
 Esdi_506.pdr  4.00.1116  8/25/97 11:16a  24,426  Windows\System\Iosubsys
 Voltrack.vxd  4.00.954   3/6/96 9:54a    18,518  Windows\System\Iosubsys

NOTE: The Voltrack.vxd file is installed on Windows 95 computers only. This file is not installed on computers running OSR2.

MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q171353
   TITLE     : Computer with Ultra DMA IDE Controller May Hang

   ARTICLE-ID: Q161642
   TITLE     : Auto Insert Notification May Prevent Automatic Suspend

   ARTICLE-ID: Q160800
   TITLE     : "Fatal Exception Error" with Iomega IDE Zip Drives

   ARTICLE-ID: Q154976
   TITLE     : Error Message Running Jet Database Engine Stress Test

   ARTICLE-ID: Q154436
   TITLE     : Errors Accessing Hard Disk with Spin-Down Enabled

   ARTICLE-ID: Q154435
   TITLE     : Windows 95 IDE Support for SMART, DMA, and ATAPI Tape
               Drives


Additional query words: 95 pcmcia
Keywords : win95 windrvr kbfile kbhw kbfixlist
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: January 8, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.