File May Be Truncated When Copied to a Full Network Drive

Last reviewed: January 9, 1997
Article ID: Q161100
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1

SYMPTOMS

If you use Windows Explorer on a Windows 95-based computer to copy a file to an SMB (Server Message Block) server using the Microsoft Client for Microsoft Networks, the file may be truncated if the server's disk is full or nearly full.

The copy operation may seem to succeed, and no error message is displayed. However, some data at the end of the file may be lost.

CAUSE

This can occur if the amount of free disk space on the server is slightly less than the size of the file being copied.

RESOLUTION

Make sure that the disk on the network server contains sufficient free space for the file being copied.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95. A fix to this problem is in development, but has not been regression tested and may be destabilizing in production environments. Microsoft does not recommend implementing this fix at this time. Contact Microsoft Technical Support for more information about the availability of this fix.

MORE INFORMATION

If the operation being performed is a move operation instead of a copy operation, or if the original file is deleted after being copied, the lost data may not be recoverable except by restoring from a recent backup.


KBCategory: kbnetwork kbenv
KBSubcategory: win95 osr2
Additional reference words: 95


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Last reviewed: January 9, 1997
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