Computer Hangs When Using the DIR Command in DFS Shared Folders

Last reviewed: February 16, 1998
Article ID: Q181087
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1, 2.5
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

When you use the DIR command from a command prompt on a Windows 95 Distributed File System (DFS) client to view the contents of a DFS shared network folder on a Windows NT server, your computer may stop responding (hang).

CAUSE

This behavior can occur for any of the following reasons:

  • The current folder in which you are using the DIR command is several levels down on the DFS shared network drive. For example, this behavior can occur if you use the DIR command in Folder5 of the following path

          <drive>:\Folder1\Folder2\Folder3\Folder4\Folder5
    

    where <drive> is the mapped drive to the DFS shared network folder.

  • The DFS volume on the Windows NT server has a volume label.

RESOLUTION

This issue is resolved by the following updated file for Windows 95 and Windows 95 OEM Service Release 2 (OSR2):

    Dfs.vxd  version 4.10.1686 dated 2/6/98 7:26pm 18,147 bytes

To work around this issue, remove the volume label from the DFS volume on the Windows NT server.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95 and Windows 95 OEM Service Release 2 (OSR2). An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time. Contact Microsoft Technical Support for additional information about the availability of this update.


Additional query words: 4.00
Keywords : win95 winnt kbnetwork
Version : WINDOWS:95; WINNT:4.0
Platform : WINDOWS winnt
Issue type : kbprb


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 16, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.