Security Log Close Handles Don't Match Open Handles

Last reviewed: August 28, 1996
Article ID: Q131059
The information in this article applies to:
  • Microsoft Windows NT Workstation version 3.5
  • Microsoft Windows NT Server version 3.5

SYMPTOMS

About half the close audit entries in the security log display the same constant value for handle identification numbers (IDs), even though those handle IDs are supposed to match the open audit routine handle IDs which vary.

NOTE: You can still follow the audit trail in the Security log and find a corresponding open audit entry for each close audit entry, but the handle IDs in the close audit entries will be wrong.

CAUSE

The service controller handle ID passing routine does not always correctly pass along the handle IDs.

RESOLUTION

To resolve this problem, upgrade to Windows NT version 3.51.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 3.5. This problem was corrected in Windows NT version 3.51.


KBCategory: kbother kbbug3.50 kbfix3.51
KBSubcategory: ntsecurity NTSrvWkst
Additional reference words: prodnt 3.50


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: August 28, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.