Scheduled RASDIAL Fails To Connect to Windows NT RAS Server

Last reviewed: March 26, 1997
Article ID: Q147711
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.5 and 3.51
  • Microsoft Windows NT Server versions 3.5 and 3.51
  • Microsoft Windows NT Server version 4.0
  • Microsoft Windows NT Workstation version 4.0

SYMPTOMS

When you use the Windows NT Scheduler Service and schedule RASDIAL.EXE to automatically connect to a Windows NT Remote Access Service (RAS) server, the following symptoms occur if you do not specify a user account for the RASDIAL command:

   - The Windows NT RAS server disconnects the Windows NT RAS client during
     authentication.

   - If you schedule the RASDIAL command to run interactively (with the
     /INTERACTIVE switch) in the MS-DOS Command Prompt (CMD.EXE), the CMD
     window stops responding (hangs).

   - The system that scheduled the RASDIAL command may become unstable and
     you may not be able to start new applications.

CAUSE

When you do not specify a user account in RASDIAL, RASDIAL uses the current user name and password. By default, the Scheduler service logs on with the System account. Therefore, if you do not change the "Log On As" account for the Scheduler service and you do not specify a user name and password on the RASDIAL command line, the scheduled RASDIAL command uses the System account when it attempts to connect to the Windows NT RAS server. If the System account is used, the symptoms mentioned above occurs.

RESOLUTION

To correct this problem, do one of the following:

  • Enter a user name and password as parameters on the RASDIAL command line in the following format:

          RASDIAL <Entry Name> <User Name> <Password>
    

    The user name you specify must have RAS dial-in permission on the RAS server.

    -or-

  • Change the "Log On As" account for the Scheduler service to an account other than the System account. The account that you select must have RAS dial-in permission on the Windows NT RAS server.


Additional query words: prodnt
Keywords : kbnetwork ntras NTSrvWkst
Version : 3.5 3.51 4.0
Platform : WinNT


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 26, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.