Client-based Network Administration Tools Give Access Denied

Last reviewed: June 16, 1997
Article ID: Q151506
The information in this article applies to:

- Microsoft Windows NT Workstation versions 3.51 and 4.0

SYMPTOMS

The installation of the Client-based Network Administration Tools from the Windows NT Server CD-ROM on a Windows NT Workstation may fail with the following error message:

   Access Denied

CAUSE

This problem may arise when one of the files copied by Setup.bat already exists in the %SYSTEMROOT%\System32 or %SYSTEMROOT%\Inf folder and is flagged with the read-only attribute.

This problem may occur in any of the following sample scenarios:

  • The Windows NT 4.0 Workstation Resource Kit was previously installed. If this is the case, some files common to both products already exist in the %SYSTEMROOT%\System32 or %SYSTEMROOT%\Inf folder and are flagged with the read-only attribute.
  • A Windows NT Service Pack was previously installed. If this is the case, some files common to both products may already exist in the %SYSTEMROOT%\System32 or %SYSTEMROOT%\Inf folder and are flagged with the read-only attribute.
  • Some or all of the files in the %SYSTEMROOT%\System32 or %SYSTEMROOT%\Inf folder which are to be overwritten by the installation process have been marked read-only before by a user with sufficient permissions.

RESOLUTION

To work around this problem, choose one of the following two methods:

Method 1

  1. Open a Command Prompt window and run the following command:

          attrib -r %systemroot%\* /s
    

    This removes the read-only flag from all files on the workstation located in the %SYSTEMROOT% folder and all its subdirectories. For more information on the ATTRIB command, see the Windows NT Help or type ATTRIB /? in a Command Prompt window.

  2. Run Setup.bat to install the Client-based Network Administration Tools on the workstation.

Method 2

  1. Copy the \Clients\Srvtools\Winnt folder and all its subdirectories to a temporary location on your hard disk.

  2. Replace each occurrence of the COPY command with the XCOPY /R command.

    The part in Setup.bat beginning with the line "echo Installing Client-based Network Administration Tools..." should then look like this:

          echo Installing Client-based Network Administration Tools...
          xcopy /r %ARCH%\*.exe %systemroot%\system32\*.* > nul:
          if errorlevel 1 goto Error_COPY
          xcopy /r %ARCH%\*.dll %systemroot%\system32\*.* > nul:
          if errorlevel 1 goto Error_COPY
          xcopy /r %ARCH%\*.hlp %systemroot%\system32\*.* > nul:
          if errorlevel 1 goto Error_COPY
          xcopy /r %ARCH%\*.cnt %systemroot%\system32\*.* > nul:
          if errorlevel 1 goto Error_COPY
          xcopy /r %ARCH%\*.adm %systemroot%\inf\*.* > nul:
          if errorlevel 1 goto Error_COPY
          xcopy /r %ARCH%\sfmmgr.dll %systemroot%\system32\sfmmgr.dll > nul:
          if errorlevel 1 goto Error_COPY
          if exist %systemroot%\system32\sfmreg.exe goto Sfm_REG
          goto Exit_SUCCESS
    

    This causes all files on the workstation to be overwritten even when they are marked as read-only. For more information on the XCOPY command, see the Windows NT Help or type XCOPY /? in a Command Prompt window.

  3. Run the modified Setup.bat.

IMPORTANT: If you install the Client-based Network Administration Tools after installing a Windows NT Service Pack, you must re-apply the previously installed Service Pack.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 3.51 and 4.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

The installation is started by opening a Command Prompt, changing to the \Clients\Srvtools\Winnt folder on the Windows NT Server CD-ROM, and running Setup.bat.


Additional query words: 3.51 4.00 prodnt install setup utility utilities
admin tools
Keywords : kbsetup kbtool ntsetup ntutil NTWkst
Version : 3.51 4.0
Platform : winnt


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Last reviewed: June 16, 1997
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