Cannot Resolve Hostname with DNS

Last reviewed: April 30, 1997
Article ID: Q162712
The information in this article applies to:
  • Microsoft Windows NT Server versions 3.51, 4.0
  • Microsoft Windows NT Workstation versions 3.51, 4.0

SYMPTOMS

You may be unable to resolve a computer's hostname with Domain Name System (DNS) name resolution even though your settings are mapped to a known good DNS server.

CAUSE

This behavior can occur if the AFD Networking Support Environment (Afd.sys) is either disabled or has not started properly.

RESOLUTION

To resolve this issue, follow these steps:

  1. In Control Panel, double-click Devices.

  2. Click AFD Networking Support Environment.

  3. Click Startup.

  4. Click Automatic, and then click OK.

  5. Click Close, and then shut down and restart the computer.

  6. In Control Panel, double-click Devices. Verify that the AFD Networking Support Environment is started.

STATUS

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Additional query words: prodnt
Keywords : kbnetwork nttcp
Version : 3.51 4.0
Platform : WinNT


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: April 30, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.