STOP 0x0A Due to Duplicate Free in Afd.sys

Last reviewed: February 3, 1998
Article ID: Q179741
The information in this article applies to:
  • Microsoft Windows NT Workstation version 3.51 and 4.0
  • Microsoft Windows NT Server version 3.51 and 4.0

SYMPTOMS

If you run SNA Server on a computer with high load and you also experience network problems, the server may stop with a STOP 0x0A error in Ntoskrnl.exe.

NOTE: This problem may also happen in other situations.

CAUSE

In the situation above, there were code paths used in Afd.sys where data structures happened to be freed twice.

RESOLUTION

To resolve this problem, obtain the following fix or wait for the next Windows NT service pack.

Windows NT 4.0

This fix should have the following time stamp:

   12/09/97  05:36p                63,888 Afd.sys (Intel)
   12/09/97  05:33p               112,400 Afd.sys (Alpha)

Windows NT 3.51

This fix should have the following time stamp:

   12/09/97  07:47p                52,272 Afd.sys (Intel)
   12/09/97  07:44p                88,880 Afd.sys (Alpha)

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Microsoft has confirmed this to be a problem in Windows NT version 3.51. A supported fix is now available, but is not fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Product Support Services for more information.

Keywords          : kbbug3.51 kbbug4.00 kbfix3.51 kbfix4.00 NTSrvWkst
Version           : WinNT:3.51,4.0
Issue type        : kbbug
Solution Type     : kbfix


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 3, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.