Dial-Up Networking Password Is Not Saved

Last reviewed: March 17, 1998
Article ID: Q148925
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The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 98

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.

SYMPTOMS

When you try to save your password when you are making a Dial-Up Networking connection by clicking the Save Password check box, your password may not be saved. This problem can occur even when you successfully connect to the server, and when your password has not changed.

CAUSE

This problem can be caused by any of the following situations:

  • Password caching is disabled.
  • One or more of the files associated with Dial-Up Networking is missing or damaged.
  • Your password list (.pwl) file is damaged.
  • The Rna.pwl file (if it exists) is damaged.

NOTE: This problem has been known to occur after installing the Windows 95 Password List Update that is included with Microsoft Windows 95 Service Pack 1. For more information about this update, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q143003
   TITLE     : Description of Microsoft Windows 95 Service Pack 1 Updates

RESOLUTION

  1. Verify that password caching is enabled. To do so, examine the following registry key:

          HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
          Policies\Network\DisablePwdCaching
    

    If password caching is disabled, this registry value is present with a value of 1.

    NOTE: You can edit the registry using System Policy Editor (Poledit.exe) or Registry Editor (Regedit.exe). Check with your network administrator before you make any changes to the registry.

    System Policy Editor (Poledit.exe) is available in the Admin\Apptools\ Poledit folder on the Windows 95 CD-ROM. Use the Add/Remove Programs tool in Control Panel to install System Policy Editor.

    NOTE: System Policy Editor is not included in the floppy disk version of Windows 95. You can download Policy.exe, a self-extracting file containing Poledit.exe, from online services. Please see the following article in the Microsoft Knowledge Base for information about downloading Policy.exe:

          ARTICLE-ID: Q135315
    
          TITLE     : CD-ROM Extras for Microsoft Windows 95 Upgrade
    
       If password caching is disabled on your computer, use the following
       steps to edit the registry with System Policy Editor and enable pass-
       word caching in Windows 95:
    
       a. Click Start, and then click Run.
    
       b. Type "poledit" (without quotation marks) in the Open box, and then
          click OK.
    
       c. On the File menu, click Open Registry, and then double-click Local
          Computer.
    
       d. Double-click Network to expand it, and then double-click Passwords.
    
       e. Click the Disable Password Caching check box to clear it, and then
          click OK.
    
       f. Save the changes to the registry, quit System Policy Editor, and
          then restart Windows 95.
    
    

  2. Remove Dial-Up Networking, and then reinstall it. To do so, follow these steps:

    a. Click Start, point to Settings, click Control Panel, and then double-

          click Add/Remove Programs.
    

    b. Click the Windows Setup tab.

    c. Click Communications, and then click Details.

    d. Click the Dial-Up Networking check box to clear it, click OK, and

          then restart your computer if you are prompted to do so.
    

    e. Repeat steps A-C.

    f. Click the Dial-Up Networking check box to select it, and then click

          OK.
    

  3. Rename your .pwl file. To do so, type the following line at a command prompt, and then press ENTER

          ren c:\<windows>\<username>.pwl <username>.xxx
    

    where <windows> is the name of your Windows folder and <username> is the user name you use to log on to Windows 95. After renaming your .pwl file, restart your computer.

    When the Enter Network Password or Welcome To Windows dialog box appears, type the password that you normally use, and then click OK. When you are prompted to confirm the password that you entered, type the password again in the Confirm New Password box, and then click OK.

    NOTE: If there are no .pwl files present on the drive (for example, the user pressed the ESC key when prompted for a password as Windows 95 starts) password caching will not be enabled. The user must first log on to the network in order to create a .pwl file.

  4. Rename the Rna.pwl file in the Windows folder. To do so, type the following line at a command prompt, and then press ENTER:

          ren c:\<windows>\rna.pwl rna.xxx
    

    where <windows> is the name of your Windows folder. After renaming the Rna.pwl file, restart your computer.

    NOTE: The Rna.pwl file may not exist on your computer. This file is not required in some configurations.

MORE INFORMATION

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

This behavior can also occur if your computer came with Windows 95 preinstalled and is configured to automatically log on to Windows 95. To disable automatic log on, delete the AutoLogon value from the following registry key:

   HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\
   Real Mode Net

For additional information about this issue, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q141858
   TITLE     : No Windows or Network Logon Dialog Box at Startup

For additional information about problems that may occur when you attempt to save passwords in Windows 95, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q135197
   TITLE     : Damaged Password List File Does Not Save Passwords

   ARTICLE-ID: Q137361
   TITLE     : Save Password Check Box Is Unavailable

   ARTICLE-ID: Q141858
   TITLE     : No Windows or Network Logon Dialog Box at Startup


Additional query words: 95 ierelease outlook express
Keywords : kbnetwork kbtool dun win98 win95
Version : 95
Platform : WINDOWS


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Last reviewed: March 17, 1998
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